Americable - Outage for BLD 1388 – Incident details
Report an issue
Get updates
Email
Report an issue
Get updates
All systems operational
Outage for BLD 1388
Resolved
Partial outage
Started 13 days ago
Lasted about 2 hours
Affected
Internet
Partial outage from 2:20 AM to 4:26 AM
Iwakuni
Partial outage from 2:20 AM to 4:26 AM
Updates
Resolved
March 07, 2026 at 4:26 AM
Resolved
March 07, 2026 at 4:26 AM
This incident has been resolved.
Investigating
March 07, 2026 at 2:20 AM
Investigating
March 07, 2026 at 2:20 AM
We are currently investigating this incident.