Americable - Sasebo PWC Power Outage – Incident details

Experiencing minor outage

Sasebo PWC Power Outage

Resolved
Partial outage
Started 5 months agoLasted about 3 hours

Affected

Internet

Partial outage from 12:05 AM to 3:08 AM

Sasebo

Partial outage from 12:05 AM to 3:08 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Currently a unscheduled power outage at Sasebo base. PWD is investigating. Buildings 520, 539, 541, 580, 581, 582, 583 internet and TV are affected.